Networking, Security & Cloud Knowledge

Saturday, August 25, 2012

IPv6 Lab in GNS3

IPv6 test lab on GNS to Demontrate following
  1. Dual Stack
  2. MP BGP to enabel IPv6 routing
  3. HSRPv2
  4. IPv6 Autoconfiguration


IOS used: c3745-advipservicesk9-mz.124-15.T7



Setup description:

IP address / subnet details

• IPv4

o 192.168.1.0 /24 R1-R2-R3 LAN

o 192.168.3.0/24 between R1 & R4

o 192.168.5.0/24 between R2 & R4

o 192.168.4.0/24 R4 loopback

o R1 & R2 running hsrp group 2 with virtual ip 192.168.1.1



• IPv6

o 2001::/64 R1-R2-R3 LAN

o 2003::/64 between R1 & R4

o 2005::/64 between R2 & R4

o 2004::/64 R4 loopback

o R1 & R2 running hsrp v2 group 1 with auto-configured virtual ip





• BGP detail

o R1 & R2 running ibgp within AS 10

o R4 is AS 40 is running eBGP with R1 & R2 in AS 10 respectively

o R3 is used like end host with default route.



-----------------------------------------------------------------------------------------------------------


R3 Configuration

Hostname R1

!

ipv6 unicast-routing

!

interface FastEthernet0/0

ip address 192.168.1.3 255.255.255.0

duplex auto

speed auto

ipv6 address autoconfig default

end

!

ip route 0.0.0.0 0.0.0.0 192.168.1.1

!

-----------------------------------------------------------------------------------------------------------

R1 configuration

Hostname R2

!

ipv6 unicast-routing



!

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

ipv6 address 2001::1/64

standby version 2

standby 1 ipv6 autoconfig

standby 1 priority 110

standby 1 preempt

standby 1 track FastEthernet0/1 20

standby 2 ip 192.168.1.1

standby 2 priority 110

standby 2 preempt

standby 2 track FastEthernet0/1 20

end

!



interface FastEthernet0/1

ip address 192.168.3.2 255.255.255.0

duplex auto

speed auto

ipv6 address 2003::2/64

end



!

router bgp 10

no synchronization

bgp router-id 1.1.1.1

bgp log-neighbor-changes

network 192.168.1.0

neighbor 2001::2 remote-as 10

neighbor 2003::1 remote-as 40

neighbor 192.168.1.3 remote-as 10

neighbor 192.168.3.1 remote-as 40

no auto-summary



!

address-family ipv6

neighbor 2001::2 activate

neighbor 2003::1 activate

network 2001::/64

exit-address-family

!

------------------------------------------------------------------------------------------------------------

R2 Configuration



Hostname R2

!

ipv6 unicast-routing

!

interface FastEthernet0/0

ip address 192.168.1.3 255.255.255.0

duplex auto

speed auto

ipv6 address 2001::2/64

standby version 2

standby 1 ipv6 autoconfig

standby 1 preempt

standby 2 ip 192.168.1.1

standby 2 preempt

!

interface FastEthernet0/1

ip address 192.168.5.2 255.255.255.0

duplex auto

speed auto

ipv6 address 2005::2/64

!

router bgp 10

no synchronization

bgp router-id 2.2.2.2

bgp log-neighbor-changes

network 192.168.1.0

neighbor 2001::1 remote-as 10

neighbor 2005::1 remote-as 40

neighbor 192.168.1.2 remote-as 10

neighbor 192.168.5.1 remote-as 40

no auto-summary

!

address-family ipv6

neighbor 2001::1 activate

neighbor 2005::1 activate

exit-address-family

!

------------------------------------------------------------------------------------------------------------

R4 configuration

!

Hostname R4

!

ipv6 unicast-routing

!

interface Loopback0

ip address 192.168.4.1 255.255.255.0

ipv6 address 2004::1/64

!

interface FastEthernet0/0

ip address 192.168.3.1 255.255.255.0

duplex auto

speed auto

ipv6 address 2003::1/64

!

interface FastEthernet0/1

ip address 192.168.5.1 255.255.255.0

duplex auto

speed auto

ipv6 address 2005::1/64

!

router bgp 40

no synchronization

bgp router-id 4.4.4.4

bgp log-neighbor-changes

network 192.168.3.0

network 192.168.4.0

network 192.168.5.0

neighbor 2003::2 remote-as 10

neighbor 2005::2 remote-as 10

neighbor 192.168.3.2 remote-as 10

neighbor 192.168.5.2 remote-as 10

neighbor 192.168.5.2 route-map PREPEND out

no auto-summary

!

address-family ipv6

neighbor 2003::2 activate

neighbor 2005::2 activate

neighbor 2005::2 route-map PREPEND out

network 2003::/64

network 2004::/64

network 2005::/64

exit-address-family

!

route-map PREPEND permit 10

set as-path prepend 40 40 40

------------------------------------------------------------------------------------------------------------


Show commands:



R1 output







R2 output


R4 output


------------------------------------------------------------------------------------------------------------

Commands:

1 To clear ipv6 bgp neighbor

clear bgp ipv6 unicast x:x:x:x::x



No comments:

Post a Comment

Note: Only a member of this blog may post a comment.